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Introduction

In this chapter...

About this guide
New in this guide
Troubleshooting preparation




About this
guide

The Unity Troubleshooting Guide is divided into chapters relating
to general problem areas.

Each section in a chapter addresses a specific problem, which is
listed in the section title. The section contains possible causes,
in order from most to least likely to occur, when applicable. The
section also contains procedures to determine if a possible cause
applies to your situation and to resolve the problem.

When the expected result is achieved during a procedure, con-
tinue with the next step when applicable, or continue with the
next possible cause within the section.

The “Utilities” chapter contains information about how to use
utilities for researching and resolving problems. The appendix

™

contains procedures for stopping and starting Unity™.

If you encounter a problem that is not described in this guide,
contact Technical Support.

You can find compliance information for third-party electronic
devices in the manufacturer's documentation included in the
Unity package. Do not use a third-party manufacturer's docu-
mentation to install, upgrade, or manage Unity. Refer only to
Unity documentation to install, upgrade, and manage Unity.
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New in this The following table lists items that have been added to or
- changed in the Unity Troubleshooting Guide.
guide

Item Description Documentation of item

Event Notification util- Common error messages and problem resolu- “E-mail and voice error messages,”

ity tion information for this utility are provided. on page 69

Cisco® CallManager Problems and troubleshooting procedures spe- “About problems when using

integration cific to this integration are provided. the Cisco CallManager integration,”

on page 74

Fax integration Problems and troubleshooting procedures spe- “About problems with a third-party
cific to this integration are provided. fax integration,” on page 79

Live record A procedure to change the volume of the live “About live record beep tone vol-
record beep on systems equipped with Dia- ume problems when using a Dia-
logic® voice boards is provided. logic voice board,” on page 81
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Troubleshooting
preparation

Problems with external and internal calls, message notification
calls, and message waiting indicators can be caused by the
phone system, by Unity, or by both, and are therefore difficult to
diagnose. Several of the procedures for resolving problems use
the single-line test, in which the phone lines connected to Unity
are tested one at a time.

Most phone systems provide documentation on the codes that
perform transfers, recalls, and other call progress functions. Have
the phone system documentation available while performing the
procedures in this chapter.

Setting up for a single-line test

To perform diagnostic tests, you need a lineman’s test set or
an analog phone with a ringer. Additional equipment and the
method you use to set up for a single-line test depend on the
type of voice boards in the Unity server.

To set up a Dialogic D/41D or D/120 board for
single-line testing

These voice boards support two lines per jack, so you need a line
splitter to test individual lines.

© Determine which line you are having trouble with, and
unplug it from the voice board.

UNITY
SERVER

prione 8 8

SYSTEM

=4 _58

Line splitter Analog phone

(2] Plug that line into a line splitter.
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© Plug the test phone into the jack on the line splitter corre-
sponding to the port you are having trouble with. The inner
pair of wires correspond to the first port, and the outer pair
of wires correspond to the second port.

To set up a Dialogic D/41E-series board for single-line
testing

This voice board supports only one line per jack.

© Determine which line you are having trouble with, and unplug
it from the voice board.

UNITY
SERVER

prone 8 8

SYSTEM

>

Analog phone

© Plug that line into the test phone.

Continued

CHAPTER 1: Introduction 5



To set up a Dialogic D/160SC-LS for single-line testing

This voice board supports 16 lines, so you need a breakout box
to test individual lines.

(1) Unplug the amphenol connector from the telephony adapter
cable that connects to the voice board.

UNITY
SERVER

soe [ A
SYSTEM

Telephony
adapter cable

Amphenol connectors

Breakout box Analog phone

© Plug the amphenol connector into a breakout box.

© Plug the test phone into the jack on the breakout box corre-
sponding to the line you are having trouble with (one of the
first 16 jacks on the breakout box.)

Natural MicroSystems single-span and
dual-span T1

For these voice boards, you need a multifunction test set (for
example, a Sage 930A) that has the following features:

O Supervision simulation, including loop start, E & M signal-
ing, and wink detection and timing.

0 DS-1 PCM dual-direction drop/insert with D4 superframe
and ESF.

0 FXO/FXS PCM supervision.

0 Dual-direction fractional T1/DDS.

For testing information, see the documentation for the Natural
MicroSystems® voice boards and for the test set.
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s CHAPTER 2

Internal and external calls

In this chapter...

About problems with internal and external calls 8
Unity is not answering internal and/or external calls 9
Unity is not answering some internal calls 13




About problems
with internal
and external
calls

Call problems fall into two categories.

Internal and external call problems Problems that prevent
internal calls from being answered are a subset of problems that
prevent external calls from being answered. See “Unity is not
answering internal and/or external calls,” on page 9.

Internal call problems only If you determine that none of the
common possible causes for internal and external call problems
apply to your situation and the problem occurs only with some
internal calls, see “Unity is not answering some internal calls,”
on page 13.

If you encounter a call problem that is not described in this
chapter, call Technical Support.

8 UNITY TROUBLESHOOTING GUIDE



Unitv is hot Possible causes are:

?nswermg Unity was not restarted after an Exchange
internal and/or shutdown and restart

external calls

When you shut down and restart Microsoft® Exchange on the Unity
server, Unity may need to be restarted manually. For more informa-
tion, see “Shutting down and starting Unity,” on page 96.

The phone system settings are incorrect

When the phone system settings in the Unity Administrator do
not match the type of phone system that Unity is connected to,
Unity may not answer calls.

To verify the phone system settings in the Unity
Administrator

In the Unity Administrator, go to System > Switch.
In the Set Active Switch Type section, verify all values.

Correct any incorrect values for the phone system.

0000

If you changed values in step 3, click the Save icon, then
shut down and restart Unity. For more information, see
“Shutting down and starting Unity,” on page 96.

The phone system is not generating a ring
signal

In order for Unity to answer calls, the ports and trunks must be
configured correctly.

To test whether the phone system is generating a ring
signal

O Set up a test phone (Phone 1) for single-line testing. For
more information, see “I'roubleshooting preparation,” on
page 4.

Continued
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On an extension that is connected to the phone system but
that will not be connected to Unity (Phone 2), call Phone 1.

If Phone 1 rings, the phone system recognizes the port and is
generating a ring signal.

If Phone 1 does not ring, skip to step 6.

Repeat step 2 for each extension that is normally connected to
Unity.

On Phone 2, dial the access code necessary to get an exter-
nal line, then call Phone 1.

If Phone 1 rings, the trunk is configured correctly to be
answered by Unity’s ports.

If Phone 1 does not ring, skip to step 6.

Repeat step 4 for each extension that is normally connected
to Unity.

Verify the phone system programming, and change values
as necessary.

Confirm that the wiring and the jacks are securely con-
nected.

Repeat steps 1 through 5.

If Phone 1 rings for each extension tested, the phone system
is generating a ring signal and the ports and trunks are pro-
grammed correctly.

If Phone 1 still does not ring for each extension tested, call
the phone system vendor or Technical Support for the
phone system.

UNITY TROUBLESHOOTING GUIDE



Hunt groups are programmed incorrectly

Do the following procedure when the lines connected to Unity
are organized in one or more hunt groups, and the phone system
is programmed to forward calls when ports are busy.

To test hunt group programming

© Set up a test phone (Phone 1) for single-line testing. For
more information, see “I'roubleshooting preparation,” on
page 4.

© Connect Phone 1 to the last line in the first hunt group.

© Busy every extension in the first hunt group except the last
one by using the phone system programming. (The Ports
page in the Unity Administrator does not currently allow
busying of individual lines.)

O From an extension that is connected to the phone system
but that will not be connected to Unity (Phone 2), dial the
first hunt group pilot number.

If Phone 1 rings, continue with step 5.

If you hear the busy tone or if Phone 1 does not ring, verify
the phone system programming for the first hunt group and
change values as necessary, then repeat this step. If

Phone 1 still does not ring, call the phone system vendor or
Technical Support for the phone system.

Busy the last extension, so every extension in the first hunt
group is busied.

On Phone 2, dial the first hunt group pilot number again.

If you hear the busy tone, the first hunt group is pro-
grammed correctly.

If you do not hear the busy tone, verify the phone system
programming for the first hunt group and change values as
necessary, then repeat this step. If you still do not hear the
busy tone, call the phone system vendor or Technical Sup-
port for the phone system.

© Repeat steps 1 through 6 for each hunt group.

Continued
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Routing rules are not working correctly

By default, Unity does not reject any calls. If routing rules have
been changed, Unity may have been unintentionally pro-
grammed to reject internal or external calls.

To confirm that Unity routing rules are working
correctly

© On the Windows® Start menu, click Programs > Unity > Call
Viewer.

© Use the call log data in the Call Viewer to confirm that rout-
ing rules are working as intended. For more information on
using the Call Viewer, see “The Call Viewer,” on page 89. For
more information on call routing rules, see “Call routing
tables” in Chapter 10 of the Unity System Administration
Guide.

If you determine that changed routing rules are not the
source of the problem, and Unity is not answering any inter-
nal or external calls, call Technical Support. If Unity is
answering only some internal calls, skip to “Unity is not
answering some internal calls,” on page 13.

12 UNITY TROUBLESHOOTING GUIDE



Unitv is hot Possible causes are:

answe_rmg The number of ports on the system key does
some internal not match the number of ports on the voice
calls boards

When the system key is programmed for fewer voice ports than
are installed in the Unity server, Unity does not answer calls on
the extra ports. (For example, if the voice boards in the Unity
server have 48 ports but the system key is programmed for 24
ports, Unity will answer calls on only the first 24 ports.)

To verify the number of ports

© In the Unity Administrator, go to System > Licensing >
Licensed Features.

© Confirm that the “Voice ports” value matches the number of
ports on the voice boards.

If the values match, skip to the possible cause “A phone line
or voice board is not working,” on page 14.

If the “Voice ports” value is smaller than the number of
ports on voice boards in the Unity server, call your sales
representative.

A port is set incorrectly

If a port is disabled or set incorrectly, it will not answer calls.

To confirm that ports are set correctly

© In the Unity Administrator, go to System > Ports.
© Verify the settings for each port.

If a port is disabled, clear the “Out of service” check box to
enable it.

If all of the ports are enabled and set correctly, continue
with “A phone line or voice board is not working,” on
page 14.

Continued
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A phone line or voice board is not working

To isolate a problem with a phone line or voice board

© Swap the phone lines from one jack to another on a voice
board.

If the problem follows a phone line, the problem is in the
phone line.

© Swap the phone lines from a jack on one voice board to a
jack on another voice board.

If the problem follows a jack, the problem is in the jack.
(3) Swap the locations of voice boards.

If the problem follows a voice board, the problem is in the
board.

For information on testing Dialogic voice boards, see “The Uni-
versal Dialogic Diagnostics utility,” on page 93. For information
on testing Natural MicroSystems voice boards, refer to the voice
board documentation.

See also

Unity System Administration Guide:
“Voice port settings,” in Chapter 6

14 UNITY TROUBLESHOOTING GUIDE
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About call
transfer
problems

Call transfer problems fall into two categories.

Problems on a newly installed or upgraded system Call trans-
fer problems usually occur on newly installed systems or on sys-
tems that have just been upgraded.

For specific call transfer types, see “Release transfers are not
being performed correctly,” on page 17, “Supervised transfers
are not being performed correctly,” on page 20, or ““Confirm”
call transfers are not being performed correctly,” on page 25.
Also see “Calls are not transferred to the correct greeting,” on
page 28, “Unity does not respond to touchtones,” on page 30, or
“Subscriber hears a reorder tone when answering a call from
Unity,” on page 32.

Problems on an existing system See “Calls are not transferred
to the correct greeting,” on page 28, “Unity does not respond to
touchtones,” on page 30, or “Subscriber hears a reorder tone
when answering a call from Unity,” on page 32.

If you encounter a call transfer problem that is not described in
this chapter, call Technical Support.

16 UNITY TROUBLESHOOTING GUIDE



Release
transfers are
not being
performed
correctly

The symptoms of a problem with release transfers include callers
being disconnected, hearing silence, hearing the opening greet-
ing, hearing touchtones, or hearing the conference tone. Possible

causes are:

The phone system settings are incorrect

When the phone system settings in the Unity Administrator do
not match the type of phone system that Unity is connected to,

Unity may not perform release transfers correctly.

To verify the phone system settings in the Unity

Administrator

0000

In the Unity Administrator, go to System > Switch.

Correct any incorrect values for the phone system.

In the Set Active Switch Type section, verify all values.

If you changed values in step 3, click the Save icon, then

shut down and restart Unity. For more information, see

“Shutting down and starting Unity,” on page 96.

The phone system classes of service do not

allow transfers

To confirm that classes of service for the phone system

allow transfers

© Determine if the phone system supports classes of service.

© Confirm that all classes of service assigned to Unity ports
allow transfers. For more information, see the phone system

documentation.

The phone system transfer connect sequence
is programmed incorrectly

To allow callers to leave a message when an extension is busy or
not answered, each extension must be programmed to forward

calls to Unity.

CHAPTER 3: Call transfers

Continued
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To test release transfers

© Sect up a test phone (Phone 1) for single-line testing. For more
information, see “T'roubleshooting preparation,” on page 4.

© On an extension that is connected to the phone system but
that is not connected to Unity (Phone 2), dial the access
code necessary to get an external line, then call Phone 1.

Answer Phone 1.

00

On Phone 1, flash the hookswitch. You should hear a sec-
ondary dial tone.

If you do not hear a secondary dial tone within one second,
you may have flashed the hookswitch too quickly. Start
again at step 2, but flash the hookswitch a little more
slowly.

If you still do not hear a secondary dial tone, the phone sys-
tem or station programming may not allow internal trans-
fers from that extension. Verify the phone system
programming, and start again at step 2.

If you still do not hear a secondary dial tone, and if other
callers are using the system, too many people may be trying
to dial at the same time, and no DTMF receiver is available
to process your call. You may need to add DTMF receivers to
the phone system.

On Phone 1, dial a third extension (Phone 3). If the phone
system requires an override digit to force ringing, dial it.

Hang up Phone 1.

00

On Phone 2, listen for the ringback tone. If you hear the
ringback tone, continue with step 8.

If you do not hear the ringback tone, a hookflash alone may
not transfer calls. Verify the call transfer sequence in the
phone system documentation, and repeat the test.

© Answer Phone 3.

If the transfer succeeds, release transfers work on the
phone system, and the problem likely is in the Unity setup.
Continue with step 9.

If the transfer fails, verify the transfer connect sequence in
the phone system documentation and repeat the test using
the correct sequence. If the transfer still fails, call the phone
system vendor or Technical Support for the phone system.

UNITY TROUBLESHOOTING GUIDE



© The hookflash timer and transfer initiate values in the
phone system should match the comparable value in Unity’s
phone system template file. Verify the value in the phone
system documentation or in the phone system program-
ming.

(10) Verify the hookflash timer and transfer initiate values for
Unity by running the Edit Switch utility and locating the
values in the “Hookflash duration” and “Transfer initiate”
boxes.

If the phone system and Unity values do not match, call
Technical Support.

CAUTION: Do not use the Edit Switch utility to change val-
ues without calling Technical Support for assistance.

If the hookflash timer and transfer initiate values in the
phone system template file match the phone system values,
and release transfers are still not performed correctly, call
the phone system vendor or Technical Support for the
phone system.

CHAPTER 3: Call transfers 19



Supervised
transfers are
not being
performed
correctly

Possible causes are:

The phone system settings are incorrect

When the phone system settings in the Unity Administrator do
not match the type of phone system that Unity is connected to,
Unity may not perform supervised transfers correctly.

To verify the phone system settings in the Unity
Administrator

In the Unity Administrator, go to System > Switch.
In the Set Active Switch Type section, verify all values.

Correct any incorrect values for the phone system.

0000

If you changed values in step 3, click the Save icon, then
shut down and restart Unity. For more information, see
“Shutting down and starting Unity,” on page 96.

The phone system is set to forward calls when
an extension is busy
When the target extension is busy or the call is not answered, Unity

must be able to hear the busy or ringback tone, recall the call, and
route it to another extension or to the subscriber’s personal greeting.

To verify the phone system’s forward setting

© On an extension that is connected to the phone system but
that is not connected to Unity (Phone 1), call the sub-
scriber’s extension (Phone 2).

© Do not answer Phone 2.

If the call is forwarded to the operator or to another exten-
sion, then the phone system or station is set to forward calls
when the extension is busy. Continue with step 3.

If the call is not forwarded, the call forward setting for the phone
system or station is correct. Skip to the next possible cause,
“Supervised transfers are not working on the phone system.”

© Access the phone system or station set programming.

O Change the setting to not forward calls when an extension is
busy.

20 UNITY TROUBLESHOOTING GUIDE



Supervised transfers are not working on the
phone system

To test completed supervised transfers

00

o

Set up a test phone (Phone 1) for single-line testing. For
more information, see “I'roubleshooting preparation,” on
page 4.

On an extension that is connected to the phone system but
that is not connected to Unity (Phone 2), dial the access
code necessary to get an external line, then call Phone 1.

Answer Phone 1.
On Phone 1, flash the hookswitch.

If you do not hear a secondary dial tone within one second,
you may have flashed the hookswitch too quickly. Start
again at step 2, but flash the hookswitch a little more slowly.

If you still do not hear a secondary dial tone, the phone sys-
tem or station programming may not allow internal trans-
fers from that extension. Verify the phone system
programming, and start again at step 2.

If you still do not hear a secondary dial tone, and other callers
are using the system, too many people may be trying to dial
at the same time, and no DTMF receiver is available to process
your call. You may need to add DTMF receivers to the phone
system.

On Phone 1, dial a third extension (Phone 3). If the phone
system requires an override digit to force ringing, dial it.

Continued
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O If you hear the ringback tone, answer Phone 3 and hang up

Phone 1.

If you do not hear the ringback tone on Phone 1, the prob-
lem may be that a single hookflash does not transfer calls.
Verify the call transfer connect sequence in the phone sys-
tem documentation, and repeat the test by using the correct
sequence.

If the transfer succeeds, Phone 2 is connected to Phone 3,
and supervised transfers work on the phone system. The
problem likely is in the Unity setup. Continue with step 7.

If the transfer fails, verify the transfer connect sequence in
the phone system documentation and repeat the test.

The phone system may require an override digit to complete the
transfer. In the phone system documentation, determine if an
override digit is required, then repeat the test. If the transfer is
successful with an override digit, call Technical Support for
information on adding the override digit to the Unity setup.

If the transfer still fails, call the phone system vendor or
Technical Support for the phone system.

© The hookflash timer in the phone system programming

should match the comparable value in Unity’s phone system
template file. Verify the value in the phone system docu-
mentation or in the phone system programming.

© Verify the hookflash timer value for Unity by running the

Edit Switch utility and locating the value in the “Hookflash
duration” box. If the phone system and Unity values do not
match, call Technical Support.

CAUTION: Do not use the Edit Switch utility to change val-
ues without calling Technical Support for assistance.

If the hookflash timer value in the phone system template
file matches the phone system value, and supervised trans-
fers are still not performed correctly, continue with the next
possible cause, “The phone system is unable to recall unan-
swered calls.”

UNITY TROUBLESHOOTING GUIDE



The phone system is unable to recall
unanswered calls

The phone system must be able to recall calls that are unan-
swered or that are routed to busy extensions.

To test the recall sequence for unanswered calls

O Set up a test phone (Phone 1) for single-line testing. For
more information, see “T'roubleshooting preparation,” on
page 4.

© On an extension that is connected to the phone system but
that is not connected to Unity (Phone 2), dial the access
code necessary to get an external line, then call Phone 1.

© Answer Phone 1.

O On Phone 1, initiate a transfer. If a single hookflash does
not initiate a transfer on the phone system, use the
sequence you used in the procedure “To test completed
supervised transfers,” on page 21.

On Phone 1, dial a third extension (Phone 3). Do not answer
Phone 3.

After hearing a few ringback tones on Phone 1, perform the
recall sequence (usually a hookflash). This should reconnect
Phone 1 to Phone 2.

If Phone 1 is reconnected to Phone 2, the test succeeded
and the phone system is able to recall a transfer. Skip to the
next procedure, “To test the busy recall sequence.”

If Phone 1 and Phone 2 do not reconnect, verify the recall
sequence in the phone system documentation and repeat
the test with the correct sequence. If the recall sequence is
correct, or the test fails after changing the recall sequence,
run the Learn Tones utility. See “The Learn Tones utility,”
on page 90.

If the test continues to fail, call the phone system vendor or
Technical Support for the phone system.

Continued
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To test the busy recall sequence

(2]

o0

Set up a test phone (Phone 4) for single-line testing. For
more information, see “I'roubleshooting preparation,” on
page 4.

On an extension that is connected to the phone system but
that is not connected to Unity (Phone 1), dial another exten-
sion (Phone 2). Do not set Phone 1 to forward on busy, or
this test will not work.

On another extension on the phone system (Phone 3), dial
the access code necessary to get an external line, then call
Phone 4.

Answer Phone 4.

On Phone 4, initiate a transfer. If a single hookflash does
not initiate a transfer on the phone system, use the
sequence you used in “To test completed supervised trans-
fers,” on page 21.

On Phone 4, dial the busy extension (Phone 1).

After hearing the busy tone on Phone 4, perform the
busy-recall sequence (usually a hookflash). This should
reconnect Phone 4 to the original call on Phone 3.

If Phone 4 reconnects to Phone 3, the test was successful
and the phone system is able to recall transfers from busy
extensions.

If Phone 4 does not reconnect to Phone 3, verify the
busy-recall sequence in the phone system documentation
and repeat the test using the correct sequence.

If the test continues to fail, or if you need further assistance
to resolve a supervised transfer problem, call the phone sys-
tem vendor or Technical Support for the phone system.

UNITY TROUBLESHOOTING GUIDE



“Confirm”
call transfers
are not being
performed
correctly

Possible causes are:

The phone system settings are incorrect

When the phone system settings in the Unity Administrator do not
match the type of phone system that Unity is connected to, Unity
may not perform “Confirm” call transfers correctly.

To verify the phone system settings in the Unity
Administrator

In the Unity Administrator, go to System > Switch.
In the Set Active Switch Type section, verify all values.

Correct any incorrect values for the phone system.

0000

If you changed values in step 3, click the Save icon, then
shut down and restart Unity. For more information, see
“Shutting down and starting Unity,” on page 96.

The “Confirm” call transfer setting is incorrect

Problems with the “Confirm” call transfer setting can occur when
a call is accepted or when it is rejected. When “Confirm” call
transfers are not working, the phone system may completely
drop calls or may put both parties on hold.

Do both of the following procedures to determine if the problem is
with Unity’s “Confirm” call transfer setting. For more information
on how the “Confirm” setting is enabled, see “Subscriber call trans-
fer settings” in Chapter 9 of the Unity System Administration Guide.

Depending on your phone system, the dialed party may need to
hang up within 2 seconds after pressing “2” to reject the call, or
the call is transferred. The calling party may hear the “Confirm”
and/or “Introduce” prompts if the dialed party hangs up without
pressing “1” to accept or “2” to reject the call.

To test transfers in which the dialed party accepts the call

© Set up a test phone (Phone 1) for single-line testing. For more
information, see “Troubleshooting preparation,” on page 4.

Continued
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o

00000

On an extension that is connected to the phone system but
that is not connected to Unity (Phone 2), dial the access
code necessary to get an external line, then call Phone 1.

Answer Phone 1.

On Phone 1, initiate a transfer.

On Phone 1, dial another regular extension (Phone 3).
Answer Phone 3. Press “1” to accept the call.

Hang up Phone 1 to complete the transfer.

If the call is transferred to Phone 3, the test succeeded. Skip
to the next procedure, “To test transfers in which the dialed
party rejects the call.”

If the call is not transferred to Phone 3, the test failed. Call
the phone system vendor or Technical Support for the
phone system.

To test transfers in which the dialed party rejects
the call

o

0 000

Set up a test phone (Phone 1) for single-line testing. For
more information, see “T'roubleshooting preparation,” on
page 4.

On an extension that is connected to the phone system but
that is not connected to Unity (Phone 2), dial the access
code necessary to get an external line, then call Phone 1.

Answer Phone 1.
On Phone 1, initiate a transfer.

On Phone 1, dial another extension on the phone system
(Phone 3).

Answer Phone 3. Press “2” to reject the call.

Hang up Phone 3 to reject the transfer.
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© If required, perform a recall sequence (for example, a hook-
flash) on Phone 1.

If Phone 1 and Phone 2 reconnect, the test succeeded. The
problem likely is in the Unity setup, not in the phone sys-
tem. Call Technical Support.

If Phone 1 and Phone 2 do not reconnect, the test failed, and
the problem is most likely in the phone system. Call the phone
system vendor or Technical Support for the phone system.
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Calls are not
transferred to
the correct
greeting

A possible cause is:

The phone system’s forward timer is out of
sync with Unity’s “Rings to wait for” setting

For supervised transfers, the number of rings that Unity waits
before routing a call to a subscriber’s personal greeting (or to
another extension) can be reconfigured. If the phone system is
programmed to forward calls, confirm that the phone system
waits longer to forward a call than Unity waits before taking a
message.

If the phone system is forwarding the call to another extension
before Unity can take a message, the following may occur:

0 The caller does not hear the beginning of the subscriber’s
personal greeting. (For example, the subscriber’s greeting is
“Hi, this is Maria Ramirez. Please leave a message after the
tone.” But the caller hears only “...leave a message after the
tone.”)

0 The call is forwarded to another phone (for example, the
operator) rather than to the subscriber’s personal greeting.

0 The call is forwarded to the opening greeting.

0 The caller hears only ringing.

To determine whether the phone system is waiting
longer to forward a call than Unity is waiting to take a
message

© In the phone system programming, find the value of the for-
ward timer.

In the Unity Administrator, go to Subscribers >
Subscribers > Call Transfer.

o

Click the Find icon, and find the subscriber whose calls are
not being routed to the correct greeting.

o

In the Transfer Incoming Calls to Subscriber’s Phone section,
confirm that “Yes, ring subscriber’s extension” is selected.

o

In the Transfer Type section, confirm that “Supervise trans-
fer” is selected.
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O In the “Rings to wait for” box, the value should be one ring
less than the value of the phone system’s forward timer,
which you found in step 1, and no greater than “4.” This
value specifies the number of rings that Unity waits before
routing the call to the subscriber’s personal greeting.

If the values do not meet the parameters, either reprogram
the phone system so it waits longer before forwarding unan-
swered calls, or change the value in the “Rings to wait for”
box so that Unity routes the call before the phone system
forwards it.

© To change the default “Rings to wait for” value for all sub-
scribers, go to the Subscribers > Subscriber Template > Call
Transfer page.

NOTE: If you change the value in the subscriber template,
the value for existing subscriber accounts is not changed.
Changing the template affects only the value for subscriber
accounts that are created after the template is changed. For
more information on subscriber templates, see “Subscriber
templates” in Chapter 7 of the Unity System Administration
Guide.

© Determine if the phone system changes the ringback
cadence after a certain number of rings. If so, in the Unity
Administrator, set the “Rings to wait for” value to a number
less than the number of rings at the initial cadence.

© If you have determined that the phone system is waiting
longer to forward a call than Unity is waiting to take a mes-
sage, but Unity still is not routing calls to the correct greet-
ing, run the Learn Tones utility. For more information, see
“The Learn Tones utility,” on page 90.

If running the Learn Tones utility does not resolve the
problem, call Technical Support.

CHAPTER 3: Call transfers 29



Unity does not
respond to
touchtones

Possible causes are:

DTMF signal is not being sent

The first procedure is important only for feature-set phones,
because feature-set phones rely on the phone system to generate
touchtones, while analog phones generate their own touchtones.
For feature-set phones, you may need to enable touchtones on
the phone system.

If you are having trouble only with the operator console, con-
tinue with the next procedure, “To test manual DTMF signaling
on the operator console.” If you are using only analog phones to
access Unity and are having trouble with response to touch-
tones, call Technical Support.

To test manual DTMF signaling on feature-set phones

Do this procedure for each type of feature-set phone that you
use to access Unity.

© Set up a test phone (Phone 1) for single-line testing. For
more information, see “I'roubleshooting preparation,” on
page 4.

© On a feature-set phone that is connected to the phone sys-
tem but that is not connected to Unity (Phone 2), call
Phone 1. For Phone 2, use a phone that is the same type
that subscribers use to access Unity.

© Answer Phone 1.
O On Phone 2, press touchtone keys.

If you hear touchtones on Phone 1, then the type of phone
you are using for Phone 2 is sending DTMF signals to Unity.
Continue with step 5.

If you do not hear touchtones, reprogram the phone system
to provide station-to-station DTMF signaling on that line,
and repeat the test. If you still do not hear touchtones, call
the phone system vendor or Technical Support for the
phone system.
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© Connecta line-monitoring device (for example, a Ziad Line-
master) to Phone 1, and test the duration and volume of the
touchtones Phone 2 is generating. Write down the values,
and call Technical Support to determine whether touchtone
durations in the phone system template file need to be
changed. For information on setting up the line-monitoring
device, see the manufacturer’s documentation.

To test manual DTMF signaling on the operator console

© Do the previous procedure, “To test manual DTMF signaling
on feature-set phones,” but use the operator console for
Phone 2.

O Ir you hear touchtones on Phone 1, then the operator con-
sole is sending DTMF signals to Unity. The reason Unity is
not responding to touchtones is probably related to the
Unity setup. Call Technical Support.

If you cannot hear touchtones on Phone 1, the operator
console is not generating touchtones. Add a tone dialer that
generates DTMF tones, and repeat the test. If you still can-
not hear touchtones, call Technical Support.

DTMF values in Unity are inconsistent with the
values in the phone system

To compare phone system and Unity values for DTMF
duration and delay between digits

© In the phone system documentation or programming, find
and write down the duration of DTMF tones and the delay
between digits that the phone system expects from Unity.

Start the Edit Switch utility, and locate the “Dialed DTMF
duration” and “Delay between dialed DTMF digits” boxes.

© Compare the phone system values with the Unity values. If
the values do not match, call Technical Support.

CAUTION: Do not use the Edit Switch utility to change val-
ues without calling Technical Support for assistance.
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Subscriber
hears a reorder
tone when
answering

a call from
Unity

A possible cause is:

“Rings to wait” settings are incorrect

Unity requires a minimum setting of three rings to wait to prop-
erly transfer a call or to make a message notification call. If the

number of rings to wait is set to less than “3,” a subscriber may
hear the reorder tone instead of the Unity conversation.

set “Rings to wait”

In the Unity Administrator, go to Subscribers >
Subscribers > Message Notification for the subscriber.

In the Notification Options section for each device used, set
the “Wait for how many rings before hanging up” box to
three or more rings.

Go to Subscribers >Subscriber Template > Message Notifica-
tion.

In the Notification Options section for each device used, con-
firm that the “Wait for how many rings before hanging up”
box is set to three or more rings. This ensures that future
subscriber accounts get the correct default value.

Go to Call Management > Call Handlers > Call Transfer.

View the Standard, Alternate, and Closed rules. In the
Transfer Type section, if “Supervise transfer” is selected for
any of the rules, confirm that the “Rings to wait for” box is
set to three or more rings.

If “Rings to wait for” is set correctly, and the subscriber still
hears a reorder tone when answering a call from Unity, call
Technical Support.
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About problems
with messages

Message problems fall into three categories.

Messages appear to be delayed Some subscriber errors or mis-
conceptions can lead to the impression that Unity is delaying
messages. See “Messages appear to be delayed,” on page 36.

Messages seem to disappear Some Exchange and Unity situa-
tions can affect message delivery. See “Some messages seem to
disappear,” on page 38.

Messages are incomplete A setup problem may cause callers to
be cut off when they try to leave a message. See “Unity stops
recording before a caller has finished leaving a message,” on
page 39.

Begin your troubleshooting by gathering information about the
message problem. See “Researching message problems,” on
page 35.

If you encounter a message problem that is not described in this
chapter, call Technical Support.
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Researching
message
problems

See also

Unity System Administration Guide:
“Subscriber message activity
report,” in Chapter 13

Begin message troubleshooting by getting detailed information
about the problem.

Information from the subscriber

Ask the subscriber these questions. The answers may help you
determine the cause of the message problem.

O

How did you access your messages? (If possible, have the
subscriber demonstrate.)

After you logged on, what was the first thing Unity said?
On what day and at what time did you check for messages?
When did you receive the message?

According to the date and time on the message, when was
the message recorded?

How often has this problem occurred?

Subscriber message activity report

To confirm the arrival times of messages, generate a subscriber
message activity report for the subscriber. Sometimes you can
determine whether a problem is due to a subscriber’s misunder-
standing of how Unity works.
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Messages
appear to
be delayed

Possible causes are:

A subscriber exits Unity before hearing all
messages

For example, a subscriber hangs up or presses the * key repeat-
edly, exiting Unity before all messages have been played. Later,
the subscriber checks messages again and believes that the
messages not heard the first time were delayed.

Explain to the subscriber that hanging up during message
retrieval may result in not hearing all new messages.

A subscriber logs on to Unity but does not
check messages

For example, a subscriber logs on to send a message but chooses
not to listen to new messages. Later, the subscriber checks mes-
sages and hears that new messages were left before the sub-
scriber logged on the first time.

Encourage the subscriber to check new messages when logging
on to Unity.

A subscriber misunderstands the use of the
# key

For example, when a subscriber presses the # key while listening
to a message, Unity saves the message as a new message and
skips to the next message. Later, the subscriber checks mes-
sages again and hears the same message.

Explain to the subscriber that pressing the # key while a mes-
sage plays saves it as a new message.
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A subscriber’s watch does not match the
system clock

For example, if the system clock is slow or if a subscriber’s watch
or desk clock is fast, the subscriber may believe messages were
delayed.

Confirm that the system clock on the Unity server is reporting
the correct time.

A subscriber’s Exchange settings have been
changed

When settings are changed for a subscriber in Exchange, the
new values may not be reflected immediately in Unity.

Explain to the subscriber that the settings may take a few min-
utes to resynchronize, causing a delay in receipt of messages.

CHAPTER 4: Messages 37



Some messages
seem to
disappear

In some situations, messages may not be delivered to the
intended recipients. Possible causes are:

The network or a subscriber’s home Exchange
server goes down

This applies only if there are multiple Exchange servers. Increas-
ing the “Max open retries” value and decreasing the “Open inter-
val” value will increase the number of tries and decrease the wait
time Exchange uses when it tries to deliver a message after the
network or server comes back up.

Change these message transfer agent (MTA) site configuration
values, if needed, in the Exchange Administrator.

A subscriber’s Exchange mailbox is full

When a subscriber’s Exchange mailbox has exceeded the “Pro-
hibit send and receive” limit set in the Exchange Administrator,
no new messages can be sent or received. When a message recip-
ient’s mailbox is full, an undeliverable message is returned to
the sender’s mailbox.

Encourage the subscriber to dispose of messages promptly so
the Exchange mailbox does not fill up.

Undeliverable messages have not been
forwarded to recipients

Messages returned to the Unity Messaging System mailbox are
forwarded automatically to subscribers whose names appear on
the Unaddressed Messages public distribution list. The mes-
sages then must be forwarded to the intended recipients.

Explain to subscribers on the Unaddressed Messages public dis-
tribution list the importance of regularly checking for and for-
warding undeliverable messages.

A subscriber’s Exchange mailbox has been moved

When a subscriber’s Exchange mailbox is moved from one server to
another, Unity must be shut down and restarted before the sub-
scriber can access messages. For more information, see “Shutting
down and starting Unity,” on page 96.
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Unity stops
recording
before a caller
has finished
leaving a
message

Possible causes are:

The Dialogic quiet parameter is incorrect

A caller may report hearing a prompt and be prevented from com-
pleting a message, or a subscriber may report this problem after
noticing that a recording ends before the caller finished leaving a
message. This can happen when the quiet parameter is not set to
recognize low voice volume. It also can happen when a changed
quiet parameter is not retained after a Unity upgrade.

To change the Dialogic quiet parameter

Shut down Unity. For more information, see “Shutting down
and starting Unity,” on page 96.

On the Windows Start menu, click Programs > Dialogic Sys-
tem Software > Dialogic Configuration Manager-DCM.

On the Service menu, click “Stop service.” A second Dialogic
Configuration Manager window appears.

When the message “Success: Dialogic service stopped”
appears, click “Close.”

In the Service window, select a Dialogic board.

In the DCM-Properties dialog box for the board, click the
Misc tab.

Click “ParameterFile.”

In the Edit section, type quiet50.prm in the “Value” box,
and click “OK.”

Repeat steps 5 through 8 for additional Dialogic boards.

On the Service menu, click “Start service.” A second Dialogic
Configuration Manager window appears.

When the message “Success: Dialogic service started”
appears, click “Close.”

® 6 60 00 00 ©0 O O

Restart Unity. For more information, see “Shutting down
and starting Unity,” on page 96.

Continued
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Unity, the phone system, or the central office
disconnected the call

If a caller reports being cut off while leaving a message and did
not hear a prompt prior to the disconnect, Unity, the phone sys-
tem, or the central office may have disconnected the call.

To determine why the call was disconnected

o
o

On the Windows Start menu, click Programs > Administra-
tive Tools > Event Viewer.

On the Log menu, click “System.”

In the system event log, look for an error that occurred at
the time of the reported disconnected call. Double-click the
error and skip to step 6.

If no errors appear for the date and time of the disconnected
call, continue with step 4.

On the Log menu, click “Application.”

In the application event log, look for an error that occurred
at the time of the reported disconnected call. Double-click
the error.

In the Event Detail dialog box, review the contents of the
“Description” box.

If you need assistance interpreting or resolving the error, or
if no error appears in the event log that matches the date
and time of the reported disconnected call, contact
Technical Support.
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About problems
with MWis

Problems with message waiting indicators (MWIs) fall into three
categories.

MWIs are not turned on or off at all When MWIs are not work-
ing at all, a phone system integration problem or Unity setup
problem is the likely cause. See “MWIs are not being turned on
and off at all for multiple subscribers,” on page 43. Isolated com-
plaints about MWIs not working can be caused by a problem
with a subscriber’s phone. See “MWIs are not being turned on
and off at all for a subscriber,” on page 47.

MWis are turned on and off slowly Some Unity setup prob-
lems can prevent prompt activation of MWIs. See “MWIs are
being turned on and off slowly,” on page 48.

MWis are turned off intermittently Some phone systems may
require special port setup for MWIs. See “MWIs are sometimes
not being turned off,” on page 50.
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MWIS are not Possible causes are:
being turned on

and off at all . . -
- When the phone system settings in the Unity Administrator do
fOI‘ mu It'ple not match the type of phone system that Unity is connected to,

SUbscribers Unity may not turn MWIs on and off.

To verify phone system settings in the Unity
Administrator

The phone system settings are incorrect

In the Unity Administrator, go to System > Switch.
In the Set Active Switch Type section, verify all values.

Correct any incorrect values for the phone system.

0000

If you changed values in step 3, click the Save icon, then
shut down and restart Unity. For more information, see
“Shutting down and starting Unity,” on page 96.

The MWI codes are incorrect

Unity may be sending the wrong code to the phone system for
turning MWIs on or off. If the on code is wrong, MWIs will not be
turned on for any subscriber. If the off code is wrong, MWIs will
not be turned off once they have been turned on.

Some phone systems may not allow you to change MWI codes. If
that is true for your phone system, the “MWI on code” and “MWI
off code” boxes will not be available in the Unity Administrator.
For help resolving this problem, call Technical Support.

Continued
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To verify the MWI codes (analog integrations only)

© In the phone system programming or documentation, locate
and write down the codes that turn MWIs on and off.

© In the Unity Administrator, go to System > Switch.

© Compare the codes for the phone system with the codes in
the “MWI on code” and “MWI off code” boxes in the Active
Switch Settings section.

If either of the codes in the Unity Administrator is different
from the related code for the phone system, change the
value in Unity, and continue with step 4.

If both codes in the Unity Administrator are correct, call the
phone system vendor or Technical Support for the phone
system to resolve the problem.

O If you changed either value in step 3, click the Save icon,
then shut down and restart Unity. For more information,
see “Shutting down and starting Unity,” on page 96.

The phone system is not set to turn MWIs on
and off

When the phone system is not set to turn MWIs on and off, it
does not matter whether Unity is sending the codes that the
phone system is expecting. The MWIs will not be turned on or
off.

In the phone system programming, confirm that the phone sys-
tem is set to turn MWIs on and off.

UNITY TROUBLESHOOTING GUIDE



The phone system is not able to turn MWIs on
and off

To test whether the phone system can turn MWIs on
and off

© Sect up a test phone (Phone 1) for single-line testing by fol-
lowing the instructions under “Troubleshooting prepara-
tion,” on page 4. Use a line connected to a port that is set to
dial out for “Message waiting indication.”

On Phone 1, dial the code to turn on the MWI on a nearby
phone (Phone 2). Hang up Phone 1.

Confirm that the MWI on Phone 2 is on.

If the MWI is not on, call the phone system vendor or Tech-
nical Support for the phone system to resolve the problem.

On Phone 1, dial the code to turn off the MWI on Phone 2.
Hang up Phone 1.

Confirm that the MWI on Phone 2 is off.

If the MWI is not off, call the phone system vendor or Tech-
nical Support for the phone system to resolve the problem.

Repeat steps 2 through 5 for each subscriber extension, if
necessary.

O Confirm that Unity recognizes the phone system’s dial tone
by running the Learn Tones utility. For more information,
see “The Learn Tones utility,” on page 90.

If running the utility does not resolve the problem, continue
with the next possible cause, “The DTMF duration and delay
settings are incorrect.”

Continued
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The DTMF duration and delay settings are
incorrect

If Unity is dialing longer or shorter tones than the phone system
is expecting, the phone system may not realize that Unity is try-
ing to turn MWIs on and off. The same miscommunication may
occur if Unity is waiting a longer or shorter period to dial the
next digit than the phone system is expecting.

To verify the DTMF duration and delay settings

© In the phone system programming or documentation, locate
and write down the values for the duration of DTMF tones
and the delay between digits.

Start the Edit Switch utility, and locate the “Dialed DTMF
duration” and “Delay between dialed DTMF digits” boxes.

© Compare the phone system values with the Unity values.

If either of the Unity values is different from the related
phone system value, call Technical Support to correct the
value.

CAUTION: Do not use the Edit Switch utility to change val-
ues without calling Technical Support for assistance.
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MWIS are not Although rare, a possible cause is:
being turned on

and off at all o . .
- When an MWI problem is limited to a single subscriber, the sub-
fOI‘ a SUbSCl"bEl‘ scriber’s phone may have a malfunctioning MWI.

An MWI is malfunctioning

To test an MWI

© Replace the subscriber’s phone with another phone that has
a working MWI.

© Leave a test message for the subscriber.
o Confirm that the MWI is on.
If the MWI is still not working, call Technical Support.
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MWIs are being
turned on and
off slowly

Possible causes are:

Ports are too busy to turn MWIs on and off
promptly

When the ports that turn MWIs on and off are also set to perform
other operations, they may be too busy to turn MWIs on and off
promptly. You can improve MWI performance by dedicating a

smaller number of ports to turning MWIs on and off exclusively.

Systems that handle a large volume of calls may require addi-
tional ports to improve MWI performance.

To review port configuration for message waiting
indication

© In the Unity Administrator, go to System > Ports.

© Review the existing port configuration and determine if one
or more ports can be set to dial out for “Message waiting
indication” only.

Not enough ports are set for message waiting
indication

When Unity takes a lot of messages, the ports assigned to turn
MWIs on and off may not always be able to dial out promptly. A
single port set to dial out only for “Message waiting indication”
can change 240 to 360 MWIs per hour, depending on the phone
system.
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See also

Unity System Administration Guide:

“Voice port settings,” in Chapter 6

To determine if the number of message waiting
indication ports is adequate

o
(2]

In the Unity Administrator, go to Reports > System > Port
Usage.

Generate a port usage report for the ports set to dial out for
“Message waiting indication” only.

If the value of “Percentage of ports used” exceeds 40 percent
usage during peak periods, go to System > Ports in the
Unity Administrator, then continue with step 3.

If the value of “Percentage of ports used” does not exceed 40
percent usage during peak periods, then the number of
message waiting indication ports is adequate. Call Technical
Support to resolve the problem.

Review the existing port configuration and determine if one
or more additional ports can be set to dial out for “Message
waiting indication” only.
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MWIs are
sometimes not
being turned off

A possible cause is:

The phone system restricts message waiting
indication

Some phone systems require that only one port be set to turn
MWIs on and off. This means the same port that turns on an
MWTI also must turn it off. When multiple ports are set for mes-
sage waiting indication on such a phone system, MWIs may be
turned off intermittently.

To test for a phone system restriction on message
waiting indication

© Set up two test phones (Phones 1 and 2) for single-line test-

ing. For more information, see “Troubleshooting prepara-
tion,” on page 4. Use lines connected to ports that are set to
dial out for “Message waiting indication” only.

On Phone 1, dial the code to turn on the MWI on a nearby
phone (Phone 3).

On Phone 2, dial the code to turn on the MWI on another
nearby phone (Phone 4).

On Phone 1, dial the code to turn off the MWI on Phone 3.

If the MWI on Phone 3 is still on, and you have confirmed
that the MWI code you are using is correct, call Technical
Support.

On Phone 1, dial the code to turn off the MWI on Phone 4.
If the MWI is on, continue with step 6.

If the MWI is off, you can use more than one port to dial out
for MWIs, and a phone system restriction is not causing
MWIs to be turned off intermittently. Call Technical Support
to resolve the problem.

On Phone 2, dial the code to turn off the MWI on Phone 4.

If the MWI is off, this means that a port that turns on an
MWI must also be the port that turns off the MWI. In the
Unity Administrator, set only one port to dial out for “Mes-
sage waiting indication.”
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About problems
with message
notification
calls

Problems with message notification calls that Unity makes to a
subscriber’s pager, work, home, or spare phone fall into two cat-
egories.

Message notification is slow When multiple subscribers com-
plain about slow message notification, a port setup problem is
the likely cause. See “Message notification is slow for multiple
subscribers,” on page 53. Isolated complaints about slow mes-
sage notification likely are related to a subscriber’s message
notification settings. See “Message notification is slow for a sub-
scriber,” on page 54.

Message notification does not work at all Some system prob-
lems can prevent Unity from making any notification calls. See
“Message notification calls are not made to any external num-
bers,” on page 56. When a subscriber sets up message notifica-
tion incorrectly, it can prevent Unity from making any
notification calls to that subscriber. See “Message notification is
not working at all for a subscriber,” on page 57.
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Message Possible causes are:

notification S

. Ports are too busy to make notification calls
mu Itl ple When the ports that make notification calls are also set to perform
su bscri be rs other operations, they may be too busy to make notification calls

promptly. You can improve notification performance by dedicating a
smaller number of ports to making notification calls exclusively.

Systems that handle a large volume of calls may require addi-
tional ports to improve notification performance.

To review port configuration for message notification

© In the Unity Administrator, go to System > Ports.

© Review the existing port configuration and determine if one or
more ports can be set to dial out for “Message notification” only.

Not enough ports are set for “Message
notification” only

When a small number of ports are set to make notification calls
and Unity takes a lot of messages, the notification ports may not
always be able to dial out promptly.

To determine if the number of notification ports is
adequate

© In the Unity Administrator, go to Reports > System > Port
Usage.

© Generate a port usage report for the ports set to dial out for
“Message notification.”

If the value of “Percentage of ports used” exceeds 70 percent
usage during peak periods, go to System > Ports in the
Unity Administrator, then continue with step 3.

If the value of “Percentage of ports used” does not exceed 70
See also percent usage during peak periods, the number of notifica-
Unity System Administration Guide: tion ports is adequate. Call Technical Support to resolve the

“Voice port settings,” in Chapter 6 problem.

© Review the existing port configuration and determine if more
ports can be set to dial out for “Message notification” only.
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notification is

slow for a
subscriber
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Possible causes are:

Message notification setup is inadequate

When a subscriber complains that notification calls are not
being received when expected, the problem may be with the noti-

fication settings.

To determine if notification setup is adequate

(2]
o

In the Unity Administrator, go to Subscribers >
Subscribers > Message Notification for the subscriber.

In the Device list, click the correct notification device.

Confirm with the subscriber that the notification device is
appropriate for the subscriber’s needs. If the subscriber has
selected a very busy phone for Unity to call, ask if there is
an alternate phone or pager to use for message notification.

Confirm with the subscriber that the notification schedule is
consistent with the days and times that the subscriber is
available to receive notification calls.

Notification attempts are being missed

A subscriber who is frequently away from or using a notification
device may repeatedly miss notification attempts. To the sub-
scriber, it appears that Unity has delayed message notification.

To

©O 00 O

resolve missed notification attempts

In the Unity Administrator, go to Subscribers >
Subscribers > Message Notification for the subscriber.

In the Device list, click the correct notification device.

In the Notification Options section, select the “Restart notifi-
cation each time a new message arrives” check box.

In the “Try again how many times” boxes, increase the num-
ber so that Unity makes more notification calls when the
device does not answer or is busy.

In the “How many minutes to wait between tries” boxes,
decrease the number so that Unity makes notification calls
more often when the device does not answer or is busy.
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O I1n the “If notification fails...” box, select “Pager” as a backup
device if the subscriber has a pager available for use. Also
enter settings and a schedule for the pager.

© Suggest that the subscriber set up an answering machine
for the notification phone, so that notification calls are
received even when the subscriber is unavailable.

When Unity is set to call a phone that has an answering
machine, confirm with the subscriber that the answering
machine greeting is short enough so that the machine starts
recording before the notification message is repeated.

The repeat notification option is
misunderstood

Setting Unity to repeat notification at a particular interval when
there are still new messages can be useful for subscribers who
receive a lot of messages but who do not want immediate notifi-
cation. However, when a subscriber chooses not to have Unity
restart notification each time a new message arrives, setting a
long interval between repeat notification calls may lead the sub-
scriber to believe that Unity is delaying notification.

To resolve a repeat notification problem

© In the Unity Administrator, go to Subscribers >
Subscribers > Message Notification for the subscriber.

© In the Device list, click the correct notification device.

© In the Notification Options section, in the box next to the
“Repeat notification if there are still new messages after this
many minutes” check box, set a shorter interval, such as 15
minutes.

See also

Unity System Administration Guide:
“Subscriber message notification
settings,” in Chapter 9
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Message
notification
calls are not
made to any
external
numbers

A possible cause is:

Unity cannot access an external line

To make notification calls to external numbers, Unity must be
able to access an external line.

To verify external line access

O Set up a test phone (Phone 1) for single-line testing. Use a
line connected to a port that is set to dial out for “Message
notification.” For more information, see “Troubleshooting
preparation,” on page 4.

© On Phone 1, dial the access code necessary to get an exter-
nal line.

© Dial an external phone number.

If you do not reach the external number, continue with
step 4.

If you reach the number, Unity can access external lines for
message notification. Message notification settings in the
subscriber template may be preventing Unity from making
notification calls. Verify the message types and access code
in the template, and change the values if necessary. If you
make changes to the template message types or access
code, you must make the same changes to all existing sub-
scriber accounts based on the subscriber template.

O Review the phone system programming for restrictions on
external line access. Change the phone system program-
ming values as necessary, and repeat the test.

If the test fails again, call Technical Support.

56 UNITY TROUBLESHOOTING GUIDE



Message
notification is
not working at
all for a
subscriber

Possible causes are:

Only certain types of messages are set to
trigger notification

Unity can be set so that a subscriber is notified only of certain
types of messages, for example, fax and urgent voice messages.
Set that way, e-mail and regular voice messages would not cause
Unity to make a notification call.

To change the message types that trigger notification
calls

© Inthe Unity Administrator, go to Subscribers >
Subscribers > Message Notification for the subscriber.

© In the Device list, click the correct notification device.

© In the Notify Subscriber Of section, verify the selected mes-
sage types with the subscriber.

The access code for an external line is missing

To place an external call, a subscriber usually must dial an access
code to get an external line (for example, 9). When the phone sys-
tem requires an access code, an external message notification
phone number set in Unity must include the access code.

In addition, some phone systems may require a brief pause
between dialing the access code and being connected to an
external line.

To verify an access code

© Inthe Unity Administrator, go to Subscribers >
Subscribers > Message Notification for the subscriber.

In the Device list, click the correct notification device.

(2

© In the “Phone number” box, confirm that the correct access
code is included before the phone number.

0o

If the phone system requires a pause, type two commas
between the access code and the phone number (for exam-
ple, 9,,5551234).

Continued
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The notification number is incorrect or the
device is disabled or not working

The subscriber may have entered a wrong phone number for
Unity to call. Also, when a subscriber disables a phone or pager,
Unity will not attempt a notification call to the device regardless
of the other notification settings.

To verify a device phone number and status

© In the Unity Administrator, go to Subscribers >
Subscribers > Message Notification for the subscriber.

In the Device list, click the correct notification device.

© In the “Phone number” box, confirm that the correct access
code and phone number are entered for the device.

In the Status section, confirm that the device is set to
“Enabled.”

To test whether a device is working

© If the notification device is a cellular phone or pager, ask the
subscriber to have it available for the test.

If the notification device is a home phone or another phone
away from the office, ask the subscriber to have someone
available to answer the phone during the test.

© Confirm that the notification device is on.

© Set up a test phone (Phone 1) for single-line testing. Use a
line connected to a port that is set to dial out for “Message
notification.” For more information, see “Iroubleshooting
preparation,” on page 4.

© On Phone 1, dial the notification number set in Unity for the
device.

If the pager is activated or the phone rings, you have con-
firmed that Unity can call the device.

If the pager is not activated or the phone does not ring,

See also there may be a problem with the device. Consult the device
Unity System Administration Guide: manufacturer’s documentation, or ask the subscriber to
“Subscriber message notification obtain a different notification device and repeat the test.

settings,” in Chapter 9
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Error messages
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Blue-screen error orvideo compatibility error afterinstalling
pcAnywhere 71




About error
messages

Error messages fall into four categories:

Startup error messages For information about error messages
that may appear when Unity is started, see “Startup error mes-
sages,” on page 61.

Browser error messages For information about error messages
that may appear during a logon attempt to the Unity Administra-
tor or the ActiveAssistant™, see “Browser error messages,” on
page 68.

E-mail and voice error messages For information about error
messages that Unity generates, see “E-mail and voice error mes-
sages,” on page 69.

pcAnywhere error message See “Blue-screen error or video
compatibility error after installing pcAnywhere,” on page 71.
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Startup error
messages

A system administrator may see the following error messages
when attempting to start Unity:

“No security key is installed. Please install the
security key, then run Setup again.”

This startup error message may appear after a new installation
or upgrade. Attach the system key to the parallel port on the
Unity server and run the Setup program again. The system key
is included in the software envelope.

If you are connecting a printer to the Unity server, plug the
printer into the parallel port on the key.

“At least one service or driver failed during
system startup.”

When one or more of the services required by Unity does not
start or one of the Unity services does not start, determine which
service failed, then follow the appropriate troubleshooting steps.

If more than one service or driver failed to start, subsequent fail-
ures may have been caused by the first failure. Do the proce-
dures to fix the first failure, then shut down and restart the
Unity server. All subsequent failures may be resolved by fixing
the first.

The procedures for this error message are meant to be followed
in the order presented.

To determine which service failed to start

© On the Windows Start menu, click Programs > Administra-
tive Tools > Event Viewer.

© On the Log menu, click “System.”

© In the System event log, find the first event in the current
startup attempt in the Date and Time columns. At startup,
events occur in rapid succession, so look for the first event
in a series of events that probably occurred just seconds apart.

Continued

CHAPTER 7: Error messages 61



62

Once you find the first event in this startup attempt, look for
the first error that occurred after it for which a stop sign
appears in the Date column.

If one or more errors appear in the System event log with a
stop sign in the Date column for the startup attempt, con-
tinue with step 5.

If no errors appear in the System event log, skip to step 6.
Look at the value in the Source column.

If the value is dlgc_log, then the problem is with the instal-
lation or configuration of the Dialogic voice boards. Skip to
the procedure “To determine what caused the Dialogic ser-
vice to fail,” on page 64.

If the Source column has any other value, call Technical
Support.

On the Log menu, click “Application.”

In the application event log, look at the event values in the
Source column.

If the source is AvVITS_Mc, then one or more of the Unity
services failed. Continue with the next procedure, “To deter-
mine what caused the Unity service to fail.”

If the source is Doh_Mc, then Exchange probably is not run-
ning. Start Exchange, then try again to start Unity. For
more information, see “Shutting down and starting Unity,”
on page 96. If this does not resolve the problem, call your
Microsoft reseller.

If the Source column contains any other value, call Techni-
cal Support.
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To determine what caused the Unity service to fail

© In the application event log, double-click the error.

© In the Event Detail dialog box, review the contents of the
“Description” box.

If the error is “Initialize security key failed,” then the system
key is probably missing or not installed correctly. Attach the
system key to the Unity server as shown in the illustration.
If you are connecting a printer to the Unity server, plug the
printer into the parallel port on the key.

Power cables

System key (parallel port]

o 2
@Q p}) @o( p}) ———— Data link (COM1)
A A ) l i
@ @ . Modem (COMZ2]
Q T Keyboard and mouse
= o
0Q)) | =
> ] Network connection
> [} Monitor
—— ]
—— ]
T E—
| —ryu|
| —rTu| Voice and fax boards
| —T |
| —rry |

If any other error appears, or if you discover that the key is
correctly installed, call Technical Support.

Continued
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To determine what caused the Dialogic service to fail

© In the Event Viewer, double-click the Dialogic error in the
System event log, and the Event Detail dialog box appears.

© In the Event Detail dialog box, review the contents of the
“Description” box, then follow the action listed for the error
in the table.

Error description

Problem and action

“No board(s) found — check system
configuration.”

No voice boards are installed, or the voice boards installed are not
seated properly, are installed in the wrong slots, or are the wrong ver-
sion. Skip to the procedure “To check switches, jumpers, and rotary
dials on each Dialogic voice board,” on page 65.

“PEB/SCBUS connection
failed /missing.”

The server contains two or more D/41ESC or D/160SC-LS voice boards,
and the boards are not all connected to one another using an SC bus
cable. Skip to the procedure “To check the SC bus cable that connects
voice boards (Dialogic D/41ESC and D/160SC-LS only), and remove
terminators,” on page 66.

Other

Continue with the next procedure, “To check the list of voice boards in
the Dialogic Configuration Manager.”

To check the list of voice boards in the Dialogic
Configuration Manager

© On the Windows Start menu, click Programs > Dialogic Sys-
tem Software > Dialogic Configuration Manager-DCM.

© In the main DCM window, under “Configured devices,” con-
firm that the list includes all the voice boards installed in
the Unity server.

If all the voice boards installed in the server appear in the
list, skip to “The Universal Dialogic Diagnostics utility,” on
page 93.

If one or more voice boards installed in the server are miss-
ing from this list, skip to the next procedure, “To check
switches, jumpers, and rotary dials on each Dialogic voice
board.”

If you have already checked the hardware settings and cable
connections, skip to the procedure “To add voice boards to
the Dialogic Configuration Manager,” on page 67.
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To check switches, jumpers, and rotary dials on each
Dialogic voice board

Each Dialogic voice board has one or more switches, jumpers, or
rotary dials that must be set correctly for the Dialogic service to
start properly.

o Attach an antistatic wrist strap.

WARNING! Always use an antistatic wrist strap when you
handle boards or other components. Static electricity can
damage the components in computer equipment.

Shut down Unity and the Unity server. For more informa-
tion, see “Shutting down and starting Unity,” on page 96.

Remove the cover from the Unity server.

O Compare the settings on the boards with the recommended
settings in Appendix A of the Unity Installation Guide, and
correct the settings as appropriate.

© Pull the voice boards out of the server and reseat them in
their slots. Moving the voice boards to different slots also
may resolve the problem.

@ If the boards are D/41ESC or D/160SC-LS voice boards,
skip to the next procedure, “To check the SC bus cable that
connects voice boards (Dialogic D/41ESC and D/160SC-LS
only), and remove terminators.”

If the boards are not D/41ESC or D/160SC-LS voice
boards, restart the Unity server. For more information, see
“Shutting down and starting Unity,” on page 96.

If Unity starts successfully, the problem is resolved.

If the error message “At least one service or driver failed
during system startup” reappears, call Technical Support.

Continued
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To check the SC bus cable that connects voice boards
(Dialogic D/41ESC and D/160SC-LS only), and remove
terminators

When the Unity server contains more than one Dialogic
D/41ESC or D/160SC-LS voice board, all the boards must be
connected to one another by using an SC bus cable.

o Attach an antistatic wrist strap.

WARNING! Always use an antistatic wrist strap when you
handle boards or other components. Static electricity can
damage the components in computer equipment.

Shut down Unity and the Unity server. For more informa-
tion, see “Shutting down and starting Unity,” on page 96.

Confirm that the red stripe on the cable connects to pin 1 on
each board, to ensure that there are no twists in the cable.

Press the connectors on the cable all the way into the con-
nectors on the boards. If the cable has more connectors
than the computer has voice boards, use the first and last
connectors and leave unused connectors in the middle of
the cable. If the end of a cable is allowed to dangle loose, it
can act as a radio antenna and pick up noise from the bus.

© The boards may have an in-line terminator in the socket
next to the SC bus connector. If there is a terminator in this
socket, remove it.

o Restart the Unity server. For more information, see “Shut-
ting down and starting Unity,” on page 96.

If Unity starts successfully, the problem is resolved.

If the error message “At least one service or driver failed
during system startup” reappears, call Technical Support.
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To add voice boards to the Dialogic Configuration
Manager

In some cases, the Dialogic Configuration Manager does not
automatically recognize all the voice boards in the Unity server.
If one or more of the boards in the server do not appear on the
list in the DCM, the missing boards are not used.

(2]
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000

On the Windows Start menu, click Programs > Dialogic Sys-
tem Software > Dialogic Configuration Manager-DCM.

In the main DCM window, under “Configured devices,” con-
firm that the list includes all the voice boards installed in
the Unity server.

If the list is complete, skip to “The Universal Dialogic Diag-
nostics utility,” on page 93.

If the list is empty or incomplete, continue with step 3.

On the Action menu, click “Add device,” and follow the
prompts.

In the Properties dialog box, click the System tab.
Verify values, depending on the voice board:

D/41D  The values for “D41DAddress” and
“D41DInterrupt” must match the switch and jumper set-
tings for each board.

D/41ESC and D/160SC-LS If the server contains more
than one D/41ESC or D/160SC-LS board:

The “BLTId” value must be different for each board. If
two or more boards have the same “BLTId” value,
change the values to make them all different.

The “BLTInterrupt” value must be the same for all
boards. If the values do not all match, change them to
match.

Click “OK” to close the Properties dialog box.
Close the DCM.

Skip to “The Universal Dialogic Diagnostics utility,” on
page 93.
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Browser error
messages

Unity administrators or subscribers may see the following error
messages:

“Access denied. Your class of service
prohibits you from accessing the Unity
Administrator Web pages.”

When this message appears during a logon attempt to the Unity
Administrator, one of the following has occurred:

0 The class of service for the logon account has been changed.
See the system administrator for more information.

0 The Unity class of service has been changed to subscriber
for everyone who previously had administrator privileges.
There is no longer a Unity account for the administrator
class of service. Call Technical Support.

“Access denied. You cannot access the
System Administration Web pages. Unity is
not running.”

When this message appears, Unity is not running. Unity must be
running before anyone can log on to the Unity Administrator.

For information, see “Shutting down and starting Unity,” on
page 96.

“Access denied. Your Windows Domain
Account [Domain\login] is not associated

with a Unity subscriber.”

When this message appears during a logon attempt to the Unity
Administrator, an invalid user name or password is being used.

Contact the system administrator to confirm the user name and
password.
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E_m ail and voice Unity administrators or subscribers may see the following error

messages:
error messages
“Voice server hard disk almost full.”

The Unity server hard disk is almost full. System logging and
TIP report data generation are terminated to conserve space.
Reclaim space on the hard disk to avoid potential loss of new

For subscribers on the Unaddressed messages and to resume logging and report generation.

Messages public distribution list, By default, the Unaddressed Messages public distribution list
create a separate Inbox folder for includes the Example Administrator. If no one is using the
returned messages. Then create a Example Administrator account, you can prevent the Unity

rule that automatically moves server hard disk from filling up with undeliverable messages by
R B Bl removing Example Administrator from the Unaddressed Mes-

ing System” from the Inbox to the sages public distribution list.
returned messages folder.

“Security key missing from voice server.”

The security key cannot be detected on the Unity server. The
system will shut down in 72 hours unless a valid security key is
attached. Confirm that the Unity system key is securely attached
to the parallel port on the Unity server. If you do not have a valid
system key, contact your sales representative.

“A conversation error has occurred.”

A conversation error has occurred, sending a caller to the fail
safe conversation. Refer to the Windows NT® or Windows 2000
application event log for more information about the error. If you
are unable to determine the source of the problem from the
information in the event log, call Technical Support.

“Account locked—logon attempt limit
reached.”

An account is locked because the limit of unsuccessful phone
logon attempts was reached. Refer to the Windows NT /2000
application event log for more information about the error. If you

are unable to determine the source of the problem from the
information in the event log, call Technical Support.

Continued
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“Voice server restart.”

The Unity server stopped responding and was restarted. Refer to
the Windows NT /2000 application event log for more informa-
tion about the error. If you are unable to determine the source of
the problem from the information in the event log, call Technical
Support.

“One or more Exchange servers in the site are
unavailable.”

The Unity server detected that one or more Exchange servers are
unavailable. Restart the Exchange server(s), and refer to the
Windows NT /2000 application event log for more information
about the error.

“Possible phone system integration failure.”

The Unity server received an inbound call with no phone system
integration information. Refer to the Windows NT /2000 applica-
tion event log for more information. If you are unable to deter-
mine the source of the problem from the information in the event
log, call Technical Support.

“System event notification.”

Notification of a system event was attempted, but the notification
text or voice message is missing or corrupt. Refer to the Windows
NT/2000 application event log for more information, and review
the notification message settings for the Event Notification util-
ity. If you are unable to determine the source of the problem
from the information in the event log, call Technical Support.

“That e-mail cannot be played at this time.”

All of the licensed text-to-speech resources are in use. Subscrib-
ers can try again later, or you may need to add more licenses.
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Blue-screen
error or video
compatibility
error after
installing
pcAnywhere

When Symantec® pcAnywhere® version 8.0 or earlier is installed
on a machine that uses Windows NT and a video chip and driver
from the ATI® Rage Pro™ series (a video chip that is installed in
Unity turnkey systems), you may encounter one of the following
problems:

0 Windows NT displays a blue-screen error when you restart.

0O pcAnywhere displays the error message “A video compatibil-
ity problem caused pcAnywhere32 to switch to the ‘compati-
bility’ video mode. To re-enable the ‘accelerated’ video mode,
choose Application Options from the File menu and reset
the video mode on the Host Operation page.”

These errors are caused by the installation program for the ATI
Rage Pro video drivers, and prevent the use of pcAnywhere to
transfer files or to perform a remote CTRL+ALT+DELETE. (The
installation program adds two drivers to the system registry but
copies only one of the drivers to the Windows NT System32
directory.) You can resolve this problem by installing two files
from the Windows NT 4.0 compact disc.

To install the video files from the Windows NT CD

© Insert the Windows NT version 4.0 disc in the CD-ROM
drive.

(2] Open a DOS window.

(3] Expand the file “8514A.d1l” from the CD to the System32
directory by using the following DOS command:

EXPAND <CD-ROM drive>:\I386\8514A.DL_
C:\<Windows NT directory>\System32\8514A.DLL

O Expand the file “8514A.sys” from the CD to the Drivers
directory by using the following DOS command:

EXPAND <CD-ROM drive>:\I386\8514A.SY_
C:\<Windows NT directory>\System32\Drivers\
8514A.SYS

Restart the computer.

00

Reinstall pcAnywhere32.

Continued
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Blue-screen error or © If either error occurs again, confirm that the files are in the

video comp atibility correct locations, have the correct date and time stamp, and
B . are the proper size, as follows:
error after installing
C:\<Windows NT directory>\System32\8514A.DLL
pcAnywhere
) 7/18/96 or newer
Continued 11:42am

39,312 bytes

C:\<Windows NT directory>\System32\Drivers\8514A.SYS
7/16/96 or newer

9:30pm

5,808 bytes
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About problems
when using

the Cisco
CallManager
integration

Problems and troubleshooting procedures specific to the Cisco
CallManager integration are described in this section. If you
encounter a problem on a system equipped with Cisco CallMan-
ager that is not listed in this section or in the general trouble-
shooting chapters, contact Technical Support.

Unity does not answer calls

Do the following two procedures to confirm that CallManager’s
call waiting feature is disabled and that call forwarding on TAPI
lines is set properly.

To confirm that call waiting is disabled

On the Cisco CallManager server, click Start > Programs >
Cisco CallManager 2.4 > CallManager Administration.

o

On the Cisco CallManager Administration toolbar, click
“Configuration.” The System screen appears.

o

Scroll down to the System Parameters area, and click
”Configure.”

Confirm that Call Waiting Enable is set to “Off.” If you
change the setting, click “Update” to save the change.

Close Cisco CallManager Administration.

To verify TAPI phone line settings

© On the Cisco CallManager server, click Start > Programs >
Cisco CallManager 2.4 > CallManager Administration.

© On the Cisco CallManager Administration toolbar, click
“Configuration,” and then click “Cisco IP phone.” The Phone
list shows the TAPI lines, IP phones, and other devices.
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© Click the name of the TAPI line you want to review. The
Device Information screen appears, showing the values
entered for that line. Verify the information on the screen by
using the following table. Correct any errors on the Device
Information screen.

Field Value

Device type “TAPI port.”

Device name Name for the TAPI port, for example, tapi_01

Description Optional. A brief description of the purpose, for example, Customer
Service

Device pool “Default pool.”

Location “Hub.”

How many lines do you want to Type 1.

assign to the device?

Directory number The extension that is connected to Unity.

Display The number that appears in a phone’s display when an external call

arrives on this line.

Forward all Leave this setting blank.

CAUTION: Do not set a value for this setting. If information appears
in this setting, Unity may operate improperly.

Forward busy The extension of the next TAPI port in sequence. If this extension is
the last TAPI port, then the extension of the first TAPI port.
If the directory number for this TAPI port is busy, calls are forwarded
to the extension shown in this setting.

Forward no answer The extension of the next TAPI port in sequence. If this extension is
the last TAPI port, then the extension of the first TAPI port.
If the directory number for this TAPI port is not answered, calls are
forwarded to the extension shown in this setting.
Forward no answer is set in the event the port is disabled or out of
service.

O Repeat step 3 for all TAPI lines.
© Close Cisco CallManager Administration.

If you have confirmed that call waiting is disabled and the
TAPI lines are set up properly, and Unity still is not answer-
ing calls, contact Technical Support.

Continued
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Callers hear the opening greeting after dialing
a subscriber’s extension

Confirm that the integration is enabled and that the phone sys-
tem settings are correct. If the settings are incorrect, call forward
to personal greeting and easy message access will not be
enabled.

To verify the integration and the phone system settings

© In the Unity Administrator, go to System > Licensing >
Licensed Features.

© In the “Integration” box, confirm that the setting is “None.”

If the setting is not “None,” contact your sales representative
for the necessary system key.

Go to System > Switch.

o
O Confirm that the settings match those in the following table.
Change the settings if necessary.

Phone system parameter Required settings
Manufacturer Cisco

Model

Switch PBX software version 2.4.3

Integration None

© Close the Unity Administrator.

If you changed any of the phone system settings in step 4,
shut down and restart the Unity server. For more informa-
tion, see “Shutting down and starting Unity,” on page 96.

If you have confirmed that the integration is enabled and
that the phone system settings are correct, and callers still
hear the opening greeting after dialing the subscriber’s
extension, call Technical Support.
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Subscribers logging on to Unity hear the
opening greeting instead of the subscriber
conversation

Confirm that the integration is enabled and that the phone sys-
tem settings are correct. Do the procedure “To verify the integra-
tion and the phone system settings,” on page 76.

If you are using the CallManager integration with Lucent, Nortel,
or Mitel phone systems, call Technical Support to add the
“MsToWaitForCalllnfo” parameter to the “Configuration” section
of the serial integration file and determine the appropriate milli-
second value. After you have added the parameter, restart Unity.
For more information, see “Shutting down and starting Unity,”
on page 96.

If you have confirmed that the integration is enabled and that
the phone system settings are correct, and you have added the
“MsToWaitForCall” parameter, and subscribers still hear the
opening greeting instead of the subscriber conversation, call
Technical Support.

No sounds play on the multimedia system
after installing the CallManager software

When a multimedia system is installed on the Unity server, reg-
istry entries for the multimedia system’s wave driver may be
overwritten when you install the Cisco wave driver. If this hap-
pens, the multimedia system no longer plays sounds. Contact
Technical Support.
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About If you encounter a problem on a system equipped with NMS T1
that is not listed in this section or in the general troubleshooting

su p ervi Sed chapters, contact Technical Support.

transfer Callor I ; o
aller hears a reorder tone during a
E;?nbg:e::z vl\\llll‘::g supervised transfer to a subscriber (NMS T1

h h systems only)
T1 integration

This problem occurs when the transfer-to extension is set to an
extension that does not exist.

To verify a transfer-to extension

© Inthe Unity Administrator, go to Subscribers >
Subscribers > Call Transfer for the subscriber.

© Confirm that the extension in the “Yes, ring subscriber at
this number” box is valid for the phone system.

If the extension is not valid, type the correct extension.

If the extension is valid, call Technical Support.
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About problems
with a
third-party fax
integration

Problems and troubleshooting procedures specific to a fax inte-
gration are described in this section. If you encounter a fax inte-
gration problem that is not listed in this section or in the general
troubleshooting chapters, contact Technical Support.

A subscriber cannot send or receive faxes

To verify a subscriber’s fax settings

(2]
o
o

In the Unity Administrator, go to Subscribers >
Subscribers > Profile for the subscriber.

Click the “View” link next to the “Class of service” box.

Confirm that the licensed features for the class of service
include “FaxMail.”

Confirm that the subscriber is listed as a fax user in the fax
server’s database.

If the subscriber is in a class of service licensed for FaxMail
and is listed as a fax user in the fax server’s database, and
still is unable to send or receive faxes, contact Technical
Support.

A subscriber cannot send an e-mail
attachment as a fax

Unity sends only attached files that have .txt, .tif, or .dcx file
name extensions.

Continued
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A subscriber’s fax did not arrive at the
destination

To research an outbound fax problem

© Verify the fax phone number. Ask the subscriber to resend
the fax to confirm that the problem was not with the receiv-
ing station or with an incorrect fax phone number.

© In the fax server administration program, look for the fax in
the outbound queue.

If the fax is there, continue with step 3.

If the fax is not there, verify the configuration of the
Exchange gateway, make changes as necessary, and resend
the fax. If the fax still is not in the queue, call Technical
Support.

© Confirm that the fax server is configured correctly for the fax
board(s) that are installed.

If the server is not configured correctly, make changes as
necessary and resend the fax.

If the server is configured correctly, then the problem is
most likely with the fax board(s). Call Technical Support.
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About Iive The troubleshooting procedure in this section is specific to a sys-
tem using Dialogic voice boards. If you encounter a live record

I‘ECOI‘d beep beep tone problem on a system equipped with Dialogic voice

tone vol ume boards that is not listed in this section or in the general trouble-

shooting chapters, contact Technical Support.
problems when

using a Dialogic The volume of the live record beep tone is too
voice board loud or too quiet (Dialogic voice boards only)

To adjust the volume of the live record beep tone

© On the Windows Start menu, click Settings > Control
Panel > Telephony. The Dialing Properties dialog box
appears.

Select “Telephony drivers.” The Dialogic TSP Configuration
dialog box appears.

Click “Advanced.”
In the Configuration Service window, select “Beep tone.”

Adjust the values in “Frequency 1” and “Amplitude 1” to
meet your needs.

Click “Apply,” then click “OK.”
In the Dialogic TSP Configuration dialog box, click “OK.”
In the Dialing Properties dialog box, click “Close.”

Shut down and restart Unity. For more information, see
“Shutting down and starting Unity,” on page 96.

® 0000 000 O

After making the frequency and amplitude adjustments, if
the beep tone is still too loud or too quiet, call Technical
Support.
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Utilities

In this chapter...

The Integration Monitor

The Call Viewer

The Learn Tones utility

The Universal Dialogic Diagnostics utility.
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The Integration
Monitor

The Integration Monitor shows the information being sent
between the phone system and Unity. Each packet of data con-
tains information on one call that the phone system forwards to
Unity. In some cases, seeing this data can help you diagnose
integration problems.

With a serial integration, you can view the packets of data that
are sent over the serial link. The Integration Monitor also dis-
plays the packets that Unity sends to the phone system, each of
which contains one MWI on or off code.

With an analog integration, you can view the packets sent over
the phone lines that connect the phone system and Unity.

To run the Integration Monitor

© Unity must be running for the Integration Monitor to display
the packets being passed to and from the Unity server. If
Unity is not running, start it. For more information see
“Shutting down and starting Unity,” on page 96.

© On the Windows Start menu, click Programs > Unity > Inte-
gration Monitor.

© Use the View menu to select display options. For more infor-
mation, see “Integration Monitor options,” on page 88.

Values displayed in the Integration Monitor

For each call the phone system sends to Unity, the Integration
Monitor displays one line of information. With a serial integra-
tion, the Integration Monitor also displays a line for each MWI on
or off code that Unity sends to the phone system.

For information on the values that appear in the Integration
Monitor, see the table “Integration Monitor fields and columns,”
on page 86. For information on menu options, see the table
“Integration Monitor options,” on page 88.

84 UNITY TROUBLESHOOTING GUIDE



Filez

The following screen shows the Integration Monitor with a serial
integration. If some of the data in a column is not visible, such
as in the Packet column below, resize the column to view the
remaining data.

Wigw

Serial Integration: MCI

 Integration Event: |
Time | Packet | Fort | Origin | Feazon | Trunk | Dialed Mumber | Calling Mumber | Forwarding Ext |
1010:29 <5Tex0l4. 1 Unknown  Frd(Busy) EEEE 4444
101020 <S5Tx:004. Outgoing Lamp Q1ff
101004 <STx:04.. 1 Unknown  Fwd[Ring no answer] jalaialal 4444
100959 <STx:0lA. Outgoing Lamp Q1ff
100852 <STx:0lA, Outgoing Lamp On
100831 <S5Tx:0lA. Outgoing Lamp On
10:07:51 «5Te04. 1 External Unknown 3421
100647 <STx:014.. 1 Unknown  Fwd(Unconditional] 4444
100615 <S5T=:04.. 1 Unknown  Fwd[Ring no answer] 4444
100551 <S5T=:04.. 1 Unknown  Frd(Busy] 4444
10:05:32 «5Te:04. 1 Internal Direct 4444
10:04:31 <5TH:014. Incaming Irvalid

The following screen shows the Integration Monitor with an ana-
log integration.

Analog Integration: watzu Adis First Digit D elay(ms] ISDDD HMest Digit Delap(ms] [20p
— Integration Event; |
Time | Packet | Port | Origin | Feazon | Trunk| Dialed Number| Calling Number | Fonwarding Et |
104137 #10123345 1 Internal Fud{Ring no answer] 345 123
10:38:13 #15695 1 External Unknown E95
103802 #22 1 Ihcoming  Disconnect
10,3248 #12345 1 Unknown  Fed(Busy] M5
10:28:57 HE345 1 Unknown  Fud({Ring no answer] 345
10:28:40 #2345 1 Internal Direct 345
10:26:06 #4345 1 Internal Direct 345
Continued
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Integration Monitor fields and columns

Field/column

Meaning

Analog integration
or
Serial integration

Immediately below the menu bar, the Integration Monitor displays the name of the
current integration and the integration type.

First digit delay (ms)
(analog integrations
only)

The amount of time that Unity waits (in milliseconds) for the first digit of a packet
to arrive after Unity answers a call. For example, to specify that the Integration
Monitor wait three seconds for the first digit to arrive, type 3000 .

CAUTION: If you change this value, you are changing the value in Unity’s
phone system template file for the current integration. Changing this value
may cause Unity to work incorrectly.

Next digit delay (ms)
(analog integrations
only)

The amount of time that Unity waits between digits for the next digit of a packet to
arrive. If the next digit does not arrive within that amount of time, Unity considers
the next digit part of another packet, and the Integration Monitor displays the digit
on a new line. For example, to specify that the Integration Monitor wait two-tenths
of a second for the next digit to arrive, type 200 .

CAUTION: If you change this value, you are changing the value in Unity’s
phone system template file for the current integration. Changing this value
may cause Unity to work incorrectly.

Time

The time at which Unity received the call from the phone system or the time at
which Unity sent an MWI on or off code to the phone system. New packets appear
at the top of the Integration Events list.

Packet

The unformatted information that the phone system sent to Unity or that Unity
sent to the phone system. The Integration Monitor uses the phone system template
file to parse the contents of the packet into the values in the remaining columns.

Port

The voice board port on the Unity server on which a call arrives from the phone
system.

86
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Field/column Meaning

Origin, Reason The Origin and Reason columns are closely related. Following is a list of values
and what the values mean.
Origin Reason Description
Internal Direct A call from a subscriber who wants to check

or send messages, or change setup options
over the phone.

External Unknown A call to Unity from an external caller who
did not log on as a subscriber. If you are
using the automated attendant, calls to the
main number will have an origin of “Exter-

nal.”

Internal Fwd (Busy) A call forwarded to Unity because an exten-

or Fwd (Ring no sion is busy, unanswered, or set to do not

Unknown answer) disturb.

Fwd (Uncondi-
tional)

Outgoing (serial Lamp on A call from Unity to the phone system to

integrations only) Lamp off turn an MWI on or off.

Incoming Digits (analog A digit that is not part of a packet because it
integrations arrived too many milliseconds after the pre-
only) vious digit. For more information, see “Next
Disconnect digit delay (ms)” earlier in this table. To dis-

play individual digits, click “Include digits”
on the View menu.

Incoming Invalid (serial A packet that Unity cannot parse because
integrations the value of the packet does not correspond
only) to any of the call types in the phone system

template file.

Incoming Disconnect A Unity subscriber repeatedly presses the ¥
key to break the connection between Unity
and the phone system.

Trunk For external calls, the phone system trunk that the call came in on.

Dialed number The number that a caller dials to reach your organization, if this information is
available.

Calling number The number that a caller is calling from. If the source of the call is external, this

value appears only if the phone system supports automatic number identification
and if the number is available.

Forwarding extension If a call is forwarded to Unity because the extension was busy, unanswered, or set
to do not disturb, this is the extension the caller dials.

Continued
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Integration Monitor options

The menus in the Integration Monitor let you save data to a file
and change the display in a variety of ways that are described in
the following table.

Menu Option Description

File Log to file To specify a file for saving Integration Monitor data.

Edit Allow delay To change the values in the “First digit delay (ms)” and “Next digit delay (ms)”
edits (analog boxes. If this option is not selected, the values are display only. For more informa-
integrations tion, see “First digit delay (ms)” and “Next digit delay (ms)” in the table “Integra-
only) tion Monitor fields and columns,” on page 86.

View Always on top  To display the Integration Monitor window in front of all other windows regardless

of which window is currently active.
To cancel the option, click it again.

View Include digits  To display individual digits that are not part of a packet because they arrived too
(analog inte- many milliseconds after the previous digit. For more information, see “Next digit
grations only) delay (ms)” in the table “Integration Monitor fields and columns,” on page 86.

View Freeze display To prevent new data packets from being displayed in the Integration Monitor win-

dow. If Unity is busy, this option can be useful for analyzing an individual packet.
Freezing the display prevents the packet from scrolling out of the window before
you can look at it.

To unfreeze the display, click the option again.

View Raw serialdata To display data from the phone system or from Unity regardless of whether the
(serial integra- Integration Monitor recognizes the data as a valid packet. If no data is displayed
tions only) in the Integration Monitor but you think it should be, try this option. There may

be no display because the Integration Monitor is unable to determine what the
pieces of the packets are.
To return to displaying formatted packets, click the option again.

View Outgoing data To display only the packets that Unity is sending to the phone system to turn
(serial integra- MWTIs on and off.
tions only) To return to displaying all packets, click the option again.

View Incoming data To display only the packets that the phone system is sending to Unity, including:

only (serial
integrations
only)

Calls forwarded to Unity because the extension is busy.
Calls forwarded to Unity because the extension is not answered.
Calls forwarded to Unity because the extension is in do not disturb mode.
Calls from subscribers who want to check or leave voice messages.
Calls from external callers who called Unity.
To return to displaying all packets, click the option again.
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The Call Viewer

For each call that the phone system integration sends to Unity,
the Call Viewer displays one line of information. This information
can be helpful when troubleshooting problems with the phone
system integration.

When troubleshooting the Cisco CallManager or Mitel® Voice-
Bridge 2000 integrations, use the Call Viewer. Unity’s Integra-
tion Monitor is not compatible with the CallManager or
VoiceBridge 2000 integrations.

To run the Call Viewer

© Unity must be running for the Call Viewer to display the
packets being passed to the Unity server. If Unity is not run-
ning, start it. For more information see “Shutting down and
starting Unity,” on page 96.

© On the Windows Start menu, click Programs > Unity > Call
Viewer.

© Use the Call Viewer window to see call information that the
phone system integration provides to Unity.
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The Learn
Tones utility

Unity comes with template files for a variety of phone systems.
These template files should work with most phone systems with-
out modification. However, problems with transfers, message
waiting indication, and message notification can arise if Unity
does not understand the phone system’s tones. If any of these
occur, run the Learn Tones utility to modify the phone system
template file.

The Learn Tones utility learns the frequency and cadence of the
phone system tones, such as busy and ringback, and teaches
them to Unity. It also learns the central office dial tone. Once you
start the utility, the process is automatic. One voice messaging
port calls other ports to generate the tones. The utility then adds
the tone information to the phone system template file.

The Learn Tones utility requires exclusive access to the ports.
Therefore, run it when Unity is not taking calls.

To run the Learn Tones utility

In the Unity Administrator, go to System > Switch.

In the Set Active Switch Type section, verify all values.
Correct any incorrect values for the phone system.

If you changed values in step 3, click the Save icon.

Shut down Unity. For more information, see “Shutting down
and starting Unity,” on page 96.

On the Windows Start menu, click Programs > Unity >
Learn Tones.

© 0 000O0O

If you want to work with the active phone system template
file, skip to step 10.

If you want to see the tone values for another phone system
template file, click “Load.”
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In the dialog box that appears, select the tones that you
want to load, and click “OK.”

Select the switch config file from the list, and click “Open.”

Confirm that all ports and extensions are correct. Do not
use a hunt group for the helper extensions.

Use manual mode when you want the primary port to call a
specified extension rather than a helper port. You will be
prompted to answer the extension and busy it. You also use
manual mode when some aspect of the phone system pro-
gramming, such as forwarding when a line is busy, conflicts
with the tone-learning process.

Type 1000 in the “Delay between calls” box.

Type 25 in the “Deviation threshold” box. Values outside
the “Deviation threshold” are discarded.

In the Dialtone section, click “Learn,” and the utility begins
learning the phone system dial tones. This may take a few
minutes.

If a “Success” message appears, continue with step 14.

If a “Failure” message appears, resolve the problem and
repeat this step. For more information, see “Troubleshooting
the Learn Tones utility,” on page 92.

In the Busy section, click “Learn,” and the utility begins
learning the phone system busy tones. This may take a few
minutes.

If a “Success” message appears, continue with step 15.

If a “Failure” message appears, resolve the problem and
repeat this step. For more information, see “Troubleshooting
the Learn Tones utility,” on page 92.

In the Ringback section, click “Learn,” and the utility begins
learning the phone system ringback tones. This may take a
few minutes.

If a “Success” message appears, continue with step 16.

If a “Failure” message appears, resolve the problem and
repeat this step. For more information, see “Troubleshooting
the Learn Tones utility,” on page 92.

Continued
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Click “Save.” (The Learn Tones utility automatically verifies
tones after it learns them, so there is no need to click “Verify
all” before saving the learned tones.)

In the dialog box that appears, select the “Dialtone,” “Busy,”
and “Ringback” check boxes, then click “OK.”

Accept the default file name, and click “Open.” Changes to
the phone system template file are saved.

Click “Done” to exit the Learn Tones utility.

00 60 ©

Restart Unity. For more information see “Shutting down and
starting Unity,” on page 96.

Troubleshooting the Learn Tones utility

If the learn tones process fails, the phone system may not be
generating a tone for a sufficient length of time. To adjust the
length of the tone that Learn Tones expects, in the Learn Tones
window change the number in the Frames column. For continu-
ous tones, one sample is one second; for tones with cadence, one
sample is one cycle.

The process may also fail if the first few seconds of the tone var-
ies from the rest of the tone. To accommodate this situation, in
the Learn Tones window change the number in the Delay col-
umn.

If you need assistance resolving these or other problems, call
Technical Support.
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The u nive rsal The Universal Dialogic Diagnostics (UDD) utility performs a wide
range of tests on the Dialogic voice boards. It is used to deter-

Dla I Oglc mine if something is wrong with one or more of the Dialogic voice
D i a g n Ostics boards in the Unity server.
utility To run the UDD utility

On the Windows Start menu, click Programs > Dialogic Sys-
tem Software > Universal Dialogic Diagnostics Utility.

Shut down the Dialogic service.

o0 ©

The UDD utility may display several warning or error mes-
sages. For each, choose the option that continues the pro-
cess of starting the utility.

Select the options required to perform all tests on all boards.
The tests take approximately five minutes per board.

When the tests are finished, the “Done” button becomes
available. Click “Done” to display additional information on
failed tests, if any.

If you get errors that you do not know how to resolve, call
Technical Support.

When you are finished reviewing test results, click “Exit
UDD.”

Shut down and restart the Unity server. For more informa-
tion, see “Shutting down and starting Unity,” on page 96.
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Shutting down
and starting Unity

In this chapter...

Shutting down and starting Unity 96




Sh utting down Unity is configured to start automatically when the Unity server

starts. You also can start and shut down Unity by using the Sta-

and starting tus Monitor.

Unity

96

To shut down Unity

© At the Unity server, log on to Windows NT/2000 as a Unity
administrator, and double-click the desktop shortcut to the
Status Monitor.

If you are at another computer, start Microsoft Internet
Explorer and go to http://<server name>/status CIf
prompted, type the Unity Administrator name and password
(by default, EAdministrator and 12345).

© Click the System Status icon.

© Indicate a shutdown method: Unity shuts down after all
calls are finished, or Unity interrupts calls in progress with
a message, disconnects all calls, then shuts down.

O Click “Shut down.” On the Unity server, an “X” appears in
the Unity icon in the status area of the taskbar when Unity
has finished shutting down.

To shut down or restart the Unity server

© Shut down Unity by using the previous procedure.

© On the Windows Start menu, click “Shut down.”

© Click “Shut down the computer” or “Restart the computer.”
During a restart, Unity starts automatically.

When Unity starts, three tones play and a check mark
appears in the Unity icon in the status area of the taskbar.

If Unity does not start successfully, two tones play and
an “X” appears in the Unity icon in the status area of the
taskbar.
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TIP

From the Unity server, you also can
start and stop Unity by right-click-
ing the Unity icon in the status area
of the taskbar, then selecting “Start
Unity” or “Stop Unity.”

To start Unity

Because Unity starts automatically when you turn on or restart
the server, you do this procedure only if you shut down Unity
but did not restart the server.

Exchange must be running before you start Unity. Like Unity,
Exchange starts automatically when you turn on or restart the
server. If you stopped Exchange manually but did not restart the
server, start Exchange before doing this procedure.

© At the Unity server, log on to Windows NT/2000 as a Unity
administrator, and double-click the desktop shortcut to the
Status Monitor.

If you are at another computer, start Internet Explorer and
go to http://<server name>/status . If prompted, type
the Unity Administrator name and password (by default,
EAdministrator and 12345).

© Click the System Status icon.
© Click “Start.”

When Unity starts, three tones play and a check mark
appears in the Unity icon in the status area of the taskbar.

If Unity does not start successfully, two tones play and an
“X” appears in the Unity icon in the status area of the task-
bar.
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a conversation error has occurred 69
access code for external line is missing 57
access denied, browser error messages 68
account
class of service prohibits logon 68
locked, logon attempt limit reached 69
Windows NT, not associated with a
subscriber 68

blue-screen error after pcANYWHERE32
installation 71
browser error messages 68

(v

call disconnected 40
call progress problems 90
call transfers
"confirm" setting is not working 25
calls not transferred to correct greeting 28
Call Viewer 89
Cisco CallManager integration
disabling the call waiting feature 74
multimedia sound system, problems with 77
phone system does not answer calls 74
subscriber incorrectly transferred to opening
greeting 76
class of service, transfer not allowed 17
"confirm" call transfer setting is not working 25
conversation error 69

data packets, viewing 84

delayed messages, causes of 36

Dialogic Configuration Manager
adding voice boards using 67
checking voice boards 64
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feature set phone signal not sent 30
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running the Learn Tones utility 90
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fax 79
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Exchange mailbox
messages not delivered when full 38
moving a subscriber’s 38
Exchange or network outage, messages not delivered
due to 38
Exchange shutdown and restart, manually starting
Unity after 96
external line
access code missing 57
use in message notification 56

F

fax
did not arrive at destination 80
subscriber can’t send e-mail attachment 79
subscriber can’t send or receive 79

feature set phones, DTMF signal problems 30

greetings, calls not transferred to correct 28

H

hunt groups not working correctly 11

1-K

icons, on/off status 97
installation problems, pcANYWHERE32 71
Integration Monitor 84
integration problems
calls not transferred to the correct greeting 28
diagnosing using Call Viewer 89
diagnosing using Integration Monitor 84
DTMF tones 90
MWTIs are not turned on and off for a
subscriber 47
MWIs are not turned on and off for multiple
subscribers 43

MWIs are turned on and off slowly 48

setting up for single-line tests 4

some internal calls not answered 13
internal calls, some not answered 13

L

lamps (MWIs)
not turned on and off for a subscriber 47
not turned on and off for multiple
subscribers 43
turned on and off slowly 48
Learn Tones utility 90
live record beep volume 81

manual DTMF signaling, feature set phones 30
message notification
busy ports 53
device not working 58
insufficient ports 53
no calls made to external numbers 56
not working for a subscriber 57
number incorrect 58
slow for a subscriber 54
slow for multiple subscribers 53
message types that trigger notification 57
messages
delayed 36
MWIs are not turned on and off for a
subscriber 47
MWIs are not turned on and off for multiple
subscribers 43
MWTIs are turned on and off slowly 48
recording stops before caller has finished
leaving a message 39
seem to disappear 38
multimedia system sound problems with Cisco
CallManager integration 77
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MWIs port configuration

not turned on and off for a subscriber 43 disabled or set incorrectly 13

not turned on and off for multiple message notification problems associated
subscribers 43 with 53

turned on and off slowly 48 system key does not match 13

possible phone system integration failure 70
preparation for troubleshooting 4

NMS T1 integration, supervised transfer problem 78 R
NMS voice boards, setting up for single-line

testing 6 release transfers not working 17
no security key is installed 61 reorder tone

caller hears during supervised transfer on a
NMS T1 system 78
o subscriber hears when answering a call 32
repeat notification 55
researching message problems 35
restart notification 55

one or more Exchange servers in the site are
unavailable 70
opening greeting
caller hears after dialing subscriber’s extension
when using Cisco CallManager integration 76
caller hears instead of personal options when
using a Cisco CallManager integration 77
operator console, DTMF signaling problem 31

restarting the Unity server 96

ring signal, testing 9

rings to wait, setting 32

routing rules not working correctly 12

S

P-Q security key missing from voice server 69

shutting down Unity 96
single-line tests, setting up to diagnose integration
problems 4

starting Unity 96

startup problem
browser error messages 68
service or driver failed during 61

Status Monitor 96

subscriber
changing Exchange settings 37
Exchange mailbox full 38
Exchange mailbox moved 38

packets, viewing values passed to and from the
phone system 84
pcANYWHERE32 problems, blue-screen error or
video-compatibility error 71
phone line not working, isolating the problem 14
phone system
does not answer calls when using Cisco
CallManager integration 74
forward on busy setting 20
template files 90
testing for a ring signal 9
transfer connect sequence incorrect 17
unable to recall unanswered calls 23
viewing packets sent to and from 84

102 UNITY TROUBLESHOOTING GUIDE



misuse of # key 36 W-2

questions for researching message problems 35
Subscriber message activity report, use in
researching message problems 35 by 68
supervised transfer
not correctly performed 20
problem when using a NMS T1 integration 78
system event notification 70

system key not installed 61

T

TAPI phone line settings, verifying 74
that e-mail cannot be played at this time 70
touchtones

no response to 30

running the Learn Tones utility 90

transfer connect sequence incorrect 17
troubleshooting preparation 4

u

unanswered calls, phone system unable to recall 23
Universal Dialogic Diagnostics utility 93
utilities

Call Viewer 89

Integration Monitor 84

Learn Tones 93
Universal Dialogic Diagnostics 93

v

voice board
add using Dialogic Configuration Manager 67
Dialogic, test using the Universal Dialogic

Diagnostics utility 93
not working, isolating the problem 14
voice server
hard disk almost full 69
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